2010年01月01日

【メモ】Windows7 64bitがブルースクリーンしまくる対応

PCをWindows7 64bitにしたのはいいけど、メモリを4GBにして以来ときどきブルースクリーンで落ちるようになったので対応をメモ。

CPU:Athlon X2 4600
M/B:ASUS A8N-SLI Deluxe
メモリモジュール: 適当に買った1GB×4枚

現象としては、ブルースクリーンで吐くコードがどうも一定しない(50とかC4とか)ので、メモリ周りがあやしいと推定。

STEP1: memtest86+ で動作確認

とりあえず1周はエラーなく完了

STEP2: BIOSの設定でMemory Remapを変更 ←今ここ

BIOSのCPUタブのDRAM Configurationを確認。RemappingオプションがHW、SWともオンになっていたので、両方ともオフにしてみた。オフにするとOSから見えるメモリ量が3GBに減った。ブルースクリーン対策として効果があるのかは不明。



というわけで、この状態でしばらく様子を見ることにします。

それにしても、64bitOSなら搭載したメモリが全部使えると思っていたのだけど、無条件ってわけじゃないんだなあ。難しい。
posted by へろ at 19:24 | Comment(4) | TrackBack(0) | コンピュータ
この記事へのコメント
ハイバネーションと再開を繰り返しながら、とりあえず安定して動いてるっぽいです。
Posted by へろ at 2010年01月09日 02:05
うちもブルースクリーン連発で悩んだ。
7インストールと併せて買ったCPU、メモリ、マザーのCPU,メモリに初期不良もあって余計。
ブルースクリーンの記録みたら、ntoskrnl.exeあたりでエラー出てた。

いろいろ試して、うちのはオンボードのJMICRONのSATAのドライバが原因とやっと確定。
大量のファイルをコピーしたりいろいろソフトインストールしたりしてみたけど、この3日ほど立ち上げっぱなしだけどブルースクリーン出ず。

メモリは8GB構成だけど、RemappingをEnableにしても全然問題ないよ。
Posted by にしち at 2010年01月09日 02:48
安定しましたかー。おつかれさまでした。

うちのA8N-SLI Deluxeは、当初RemappingオプションがないBIOSで出ていて、途中のアップデートで追加されたんですよね。なので、枯れてないというか十分な使われまくりを経ていないというか。

とりあえずPhenomII+AMD 790Xベースのマザボを買ってきたのでWindows7マシンをそれに入れ替えてみる予定。
Posted by へろ at 2010年01月09日 13:41
RemappingのSW、HWで思い出したけど、Athlon64(
Cocket939,XPRESS3200搭載マザー)で、どちらか片方のみONで4GBだったり、3.6GBぐらい(正確な数値忘れたw)だったりした。両方ONだと3.6GBくらいになってた。

4GBになる方で使ってました。参考までに。


Socket939はAsrockからつい最近出た新マザーに交換して遊んでマス。
Posted by にしち at 2010年01月10日 00:45
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/34503106

この記事へのトラックバック